Update gulp setup

- use dart sass instead of deprecated node-sass
- update bootstrap
- update node-forge
- use npm run scripts instead of directly calling node_modules/.bin/gulp
main
Jan Dittberner 2 months ago
parent e688e317db
commit 30c7ddba80

@ -26,9 +26,9 @@ for the signing operations. The instructions below have been tested on Debian
```
cd poc-browser-csr-generation
npm install --user gulp-cli
npm install --no-save --user gulp-cli
npm install
./node_modules/.bin/gulp
npm run build
```
3. Setup the example CA and a server certificate and key
@ -56,7 +56,7 @@ for the signing operations. The instructions below have been tested on Debian
the `src` directory:
```
gulp watch
npm run watch
```
## Translations

@ -3,11 +3,10 @@ const csso = require('gulp-csso');
const del = require('delete');
const rename = require('gulp-rename');
const replace = require('gulp-replace');
const sass = require('gulp-sass');
const sourcemaps = require('gulp-sourcemaps');
const uglify = require('gulp-uglify');
sass.compiler = require('node-sass');
const sass = require('gulp-sass')(require('sass'));
function clean(cb) {
del(['./public/js/*.js', './public/css/*.css'], cb);

5107
package-lock.json generated

File diff suppressed because it is too large Load Diff

@ -16,18 +16,22 @@
"devDependencies": {
"bootstrap": "^4.5.3",
"delete": "^1.1.0",
"gulp": "^4.0.2",
"gulp-csso": "^4.0.1",
"gulp": "^4.0.0",
"gulp-csso": "^4.0.0",
"gulp-rename": "^2.0.0",
"gulp-replace": "^1.0.0",
"gulp-sass": "^4.1.0",
"gulp-sass": "^5.1.0",
"gulp-sourcemaps": "^3.0.0",
"gulp-sri-hash": "^2.2.1",
"gulp-uglify": "^3.0.2",
"i18next-client": "^1.11.4",
"jquery": "^3.5.1",
"node-forge": "^0.10.0",
"popper.js": "^1.16.1"
"gulp-sri-hash": "^2.2.0",
"gulp-uglify": "^3.0.0",
"i18next-client": "^1.11.0",
"jquery": "^3.5.0",
"node-forge": "^1.3.0",
"popper.js": "^1.16.0",
"sass": "^1.56.0"
},
"dependencies": {}
"scripts": {
"build": "gulp",
"watch": "gulp watch"
}
}

Loading…
Cancel
Save